cannot use zeppelin in the kubernetes

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

cannot use zeppelin in the kubernetes

夜猫
zeppelin cannot start sucessful when i deploy it in the kubernetes. i try to delete the servie and restart pod,it can start successful,what is whrong?
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: cannot use zeppelin in the kubernetes

Park Hoon
Hi, could you describe more? For example, 

which binary did you used
what is the option (env?) starts with tcp://
processes what u did to reproduce
and so on..

It definitely helps to figure out the problem for others

Regard,

On Sat, 5 Aug 2017 at 11:17 夜猫 <[hidden email]> wrote:
zeppelin cannot start sucessful when i deploy it in the kubernetes. i try to delete the servie and restart pod,it can start successful,what is whrong?

2E06F312@2E6A7D18.B72A8559.jpg (222K) Download Attachment
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

回复: cannot use zeppelin in the kubernetes

夜猫
i use zeppelin-0.7.1,kubernet 1.6.4,here is my deploy file
apiVersion: extensions/v1beta1
kind: Deployment
metadata:
name: zeppelin-controller
namespace: dp
spec:
replicas: 1
template:
metadata:
labels:
app: zeppelin
component: zeppelin
spec:
containers:
- name: zeppelin
image: immortalhuang/zhiweicloud-zeppelin
ports:
- containerPort: 8080
resources:
requests:
cpu: 100m
command: ["/opt/zeppelin/bin/zeppelin.sh","--config","/opt/zeppelin/conf"]
volumeMounts:
- mountPath: "/opt/zeppelin"
name: code
subPath: zeppelin
ports:
- containerPort: 8080
volumes:
- name: code
persistentVolumeClaim:
claimName: dp-nas

---
kind: Service
apiVersion: v1
metadata:
name: zeppelin
namespace: dp
spec:
ports:
- port: 8090
targetPort: 8080
nodePort: 30090
selector:
component: zeppelin
type: NodePort


------------------ 原始邮件 ------------------
发件人: "Park Hoon";<[hidden email]>;
发送时间: 2017年8月5日(星期六) 下午2:08
收件人: "users"<[hidden email]>;
主题: Re: cannot use zeppelin in the kubernetes

Hi, could you describe more? For example, 

which binary did you used
what is the option (env?) starts with tcp://
processes what u did to reproduce
and so on..

It definitely helps to figure out the problem for others

Regard,

On Sat, 5 Aug 2017 at 11:17 夜猫 <[hidden email]> wrote:
zeppelin cannot start sucessful when i deploy it in the kubernetes. i try to delete the servie and restart pod,it can start successful,what is whrong?
Loading...