Plotly js file is not included in Zeppelin 0.7.1

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Plotly js file is not included in Zeppelin 0.7.1

Deenar Toraskar
Hi

I have spotted a regression between  Zeppelin 0.7.1 and  Zeppelin 0.7.0. Previously Zeppelin bundled plotly javascript files and the following code worked fine.

%spark.pyspark

 

data = [{

'z': [[1, 20, 30, 50, 1], [20, 1, 60, 80, 30], [30, 60, 1, -10, 20]],

'x': ['Monday', 'Tuesday', 'Wednesday', 'Thursday', 'Friday'],

'y': ['Morning', 'Afternoon', 'Evening'], 'type': 'heatmap'

}]

 

zplot(data, include_plotlyjs=False)



After upgrading to Zeppelin 0.7.1m the chart no longer renders. The errors show plotly.directive.js and other Javascript include not present the location Zeppelin look for them.


The error goes away if we, include_plotlyjs, but this slows down the notebooks a lot.


zplot(data, include_plotlyjs=True)


Has anyone seem this before?



Regards

Deenar