Issue with enabling helium package

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Issue with enabling helium package

stephane.davy

Hello,

 

I wish to integrate VEGA visualizations on zeppelin (version : 0.8.2) . So I created 3 files to import these visualizations on Helium :

 

-          HelloWorld.js : /home/romain/visu-vegas/Test01_HelloWorld/HelloWorld.js

-          HelloWorld.json : /home/romain/visu-vegas/Test01_HelloWorld/HelloWorld.json

-          package.json : /home/romain/visu-vegas/Test01_HelloWorld/package.json

 

This is my package.json :

{

    "name""HelloWorld",

    "description""affichage d'une phrase",

    "version""1.0.0",

    "main""HelloWorld",

    "author""",

    "license""Apache-2.0",

    "dependencies": {

        "zeppelin-tabledata""*",

        "zeppelin-vis""*",

        "vega""^5.16.1",

        "vega-embed""^6.12.2",

        "vega-lite""^4.16.7"    

    }

}

 

When I click on "enable" for import “HelloWorld” visualizations, it returns me an error whereas when I do the manipulation in command line (putty) there is no error. Below is a copy of the error.

 

To see the logs, I run a command line: "tail -f zeppelin-romain-vmlinux.log" from this directory: cd zeppelin-0.8.2-bin-all/logs.

So, here are the corresponding error logs when I click on "enable":

 

But this command goes to CLI when I'm in the bundle directory.

 

Do you have any idea why it doesn't work?

 

Thank you.

Sincerely.

 

Romain D.


smime.p7s (8K) Download Attachment