Is Spark 1.5.1 not supported by Zeppelin if I set the same as SPARK_HOME ?

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Is Spark 1.5.1 not supported by Zeppelin if I set the same as SPARK_HOME ?

Sourav Mazumder
I have an existing zeppelin build (which I built using spark 1.4). I want to try it now with Spark 1.5.1.

According to the github documentataion (https://github.com/apache/incubator-zeppelin) - "If you want to use system provided Spark and Hadoop, export SPARK_HOME and HADOOP_HOME in zeppelin-env.sh You can use any supported version of spark without rebuilding Zeppelin."

So that means I can change SPARK_HOME tothe home directory of my spark 1.5.1 and it should work.

But when I tried to start Zeppelin server with setting SPARK_HOME to 1.5.1, I get the error :

Exception in thread "main" java.lang.UnsupportedClassVersionError: org/apache/ze
ppelin/server/ZeppelinServer : Unsupported major.minor version 51.0
        at java.lang.ClassLoader.defineClass1(Native Method)
        at java.lang.ClassLoader.defineClass(ClassLoader.java:643)
        at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:14
2)
        at java.net.URLClassLoader.defineClass(URLClassLoader.java:277)
        at java.net.URLClassLoader.access$000(URLClassLoader.java:73)
        at java.net.URLClassLoader$1.run(URLClassLoader.java:212)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:323)
        at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:268)
Could not find the main class: org.apache.zeppelin.server.ZeppelinServer. Progra
m will exit.
Reply | Threaded
Open this post in threaded view
|

Re: Is Spark 1.5.1 not supported by Zeppelin if I set the same as SPARK_HOME ?

yash datta
Hi Sourav,

1.5.1 has been added  recently to the list of supported versions. Internally spark interpreter will check against a list of supported versions, before running. 

This list is here: 

spark/src/main/java/org/apache/zeppelin/spark/SparkVersion.java


This commit introduced the new spark version support :


commit 2ba4b38fb01dd3796888d5e6cbb40cb8fae90f79

Author: tribbloid <[hidden email]>

Date:   Fri Oct 2 13:42:59 2015 -0400

    upgrade spark to 1.5.1

    simple & self-explanatory

    Author: tribbloid <[hidden email]>

    Closes #333 from tribbloid/spark-1.5.1 and squashes the following commits:

    10d9465 [tribbloid] add spark 1.5.1 into the version list

    b042fc5 [tribbloid] upgrade spark to 1.5.1 



You can build zeppelin from master, then it will work with spark 1.5.1

Best Regards
Yash


On Thu, Oct 15, 2015 at 11:08 PM, Sourav Mazumder <[hidden email]> wrote:
I have an existing zeppelin build (which I built using spark 1.4). I want to try it now with Spark 1.5.1.

According to the github documentataion (https://github.com/apache/incubator-zeppelin) - "If you want to use system provided Spark and Hadoop, export SPARK_HOME and HADOOP_HOME in zeppelin-env.sh You can use any supported version of spark without rebuilding Zeppelin."

So that means I can change SPARK_HOME tothe home directory of my spark 1.5.1 and it should work.

But when I tried to start Zeppelin server with setting SPARK_HOME to 1.5.1, I get the error :

Exception in thread "main" java.lang.UnsupportedClassVersionError: org/apache/ze
ppelin/server/ZeppelinServer : Unsupported major.minor version 51.0
        at java.lang.ClassLoader.defineClass1(Native Method)
        at java.lang.ClassLoader.defineClass(ClassLoader.java:643)
        at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:14
2)
        at java.net.URLClassLoader.defineClass(URLClassLoader.java:277)
        at java.net.URLClassLoader.access$000(URLClassLoader.java:73)
        at java.net.URLClassLoader$1.run(URLClassLoader.java:212)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:323)
        at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:268)
Could not find the main class: org.apache.zeppelin.server.ZeppelinServer. Progra
m will exit.



--
When events unfold with calm and ease
When the winds that blow are merely breeze
Learn from nature, from birds and bees
Live your life in love, and let joy not cease.
Reply | Threaded
Open this post in threaded view
|

Re: Is Spark 1.5.1 not supported by Zeppelin if I set the same as SPARK_HOME ?

Ranveer Kumar-2

I have build zeppelin with spark 1.5.1 and facing no issue.  May be as you compiled with older version so giving problem. Try to build with 1.5.1

Regards
Ranveer


On Thu, 15 Oct 2015 23:23 yash datta <[hidden email]> wrote:
Hi Sourav,

1.5.1 has been added  recently to the list of supported versions. Internally spark interpreter will check against a list of supported versions, before running. 

This list is here: 

spark/src/main/java/org/apache/zeppelin/spark/SparkVersion.java


This commit introduced the new spark version support :


commit 2ba4b38fb01dd3796888d5e6cbb40cb8fae90f79

Author: tribbloid <[hidden email]>

Date:   Fri Oct 2 13:42:59 2015 -0400

    upgrade spark to 1.5.1

    simple & self-explanatory

    Author: tribbloid <[hidden email]>

    Closes #333 from tribbloid/spark-1.5.1 and squashes the following commits:

    10d9465 [tribbloid] add spark 1.5.1 into the version list

    b042fc5 [tribbloid] upgrade spark to 1.5.1 



You can build zeppelin from master, then it will work with spark 1.5.1

Best Regards
Yash


On Thu, Oct 15, 2015 at 11:08 PM, Sourav Mazumder <[hidden email]> wrote:
I have an existing zeppelin build (which I built using spark 1.4). I want to try it now with Spark 1.5.1.

According to the github documentataion (https://github.com/apache/incubator-zeppelin) - "If you want to use system provided Spark and Hadoop, export SPARK_HOME and HADOOP_HOME in zeppelin-env.sh You can use any supported version of spark without rebuilding Zeppelin."

So that means I can change SPARK_HOME tothe home directory of my spark 1.5.1 and it should work.

But when I tried to start Zeppelin server with setting SPARK_HOME to 1.5.1, I get the error :

Exception in thread "main" java.lang.UnsupportedClassVersionError: org/apache/ze
ppelin/server/ZeppelinServer : Unsupported major.minor version 51.0
        at java.lang.ClassLoader.defineClass1(Native Method)
        at java.lang.ClassLoader.defineClass(ClassLoader.java:643)
        at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:14
2)
        at java.net.URLClassLoader.defineClass(URLClassLoader.java:277)
        at java.net.URLClassLoader.access$000(URLClassLoader.java:73)
        at java.net.URLClassLoader$1.run(URLClassLoader.java:212)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:323)
        at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:268)
Could not find the main class: org.apache.zeppelin.server.ZeppelinServer. Progra
m will exit.



--
When events unfold with calm and ease
When the winds that blow are merely breeze
Learn from nature, from birds and bees
Live your life in love, and let joy not cease.