Building Zeppelin on Mapr 5.2 MEP 3.0 Fails with error below

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Building Zeppelin on Mapr 5.2 MEP 3.0 Fails with error below

ligaroba@gmail.com
Hi Am building zeppelin on mapr 5.2 MEP 3.0
COMMAND USED
mvn clean package -DskipTests -Pmapr50 -Pscalding -Dignite.version=1.9.0 -Pcassandra-spark-1.5   -Dhbase.hbase.version=1.1.8 -Pspark-2.1 -Phadoop-2.7 -Pyarn -Ppyspark -Psparkr -Pscala-2.11


ERROR RECEIVED
Java HotSpot(TM) 64-Bit Server VM warning: ignoring option MaxPermSize=1024m; support was removed in 8.0
[INFO] Scanning for projects...
Downloading: https://repo.maven.apache.org/maven2/org/apache/apache/17/apache-17.pom
[ERROR] [ERROR] Some problems were encountered while processing the POMs:
[FATAL] Non-resolvable parent POM for org.apache.zeppelin:zeppelin:0.8.0-SNAPSHOT: Could not transfer artifact org.apache:apache:pom:17 from/to central (https://repo.maven.apache.org/maven2): repo.maven.apache.org: Name or service not known and 'parent.relativePath' points at wrong local POM @ line 32, column 11
 @
[ERROR] The build could not read 1 project -> [Help 1]
[ERROR]  
[ERROR]   The project org.apache.zeppelin:zeppelin:0.8.0-SNAPSHOT (/opt/zeppelin/zeppelin/pom.xml) has 1 error
[ERROR]     Non-resolvable parent POM for org.apache.zeppelin:zeppelin:0.8.0-SNAPSHOT: Could not transfer artifact org.apache:apache:pom:17 from/to central (https://repo.maven.apache.org/maven2): repo.maven.apache.org: Name or service not known and 'parent.relativePath' points at wrong local POM @ line 32, column 11: Unknown host repo.maven.apache.org: Name or service not known -> [Help 2]
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/ProjectBuildingException
[ERROR] [Help 2] http://cwiki.apache.org/confluence/display/MAVEN/UnresolvableModelException

Reply | Threaded
Open this post in threaded view
|

Re: Building Zeppelin on Mapr 5.2 MEP 3.0 Fails with error below

Michael Segel
Hi,

Why are you using  -Pmapr50 instead of -Pmapr51  (There is no 5.2)

You’re building against 0.8.0 which isn’t the latest ‘stable’ release.

I’ve had issues building a MapR release against 7.3 but could build against 7.2
(Albeit I’ve had some issues along the way.)

Also why the added HBase?  

Is there any reason why you couldn’t go back to 7.2 and try that release?

> On Oct 19, 2017, at 4:44 AM, [hidden email] wrote:
>
> Hi Am building zeppelin on mapr 5.2 MEP 3.0
> COMMAND USED
> mvn clean package -DskipTests -Pmapr50 -Pscalding -Dignite.version=1.9.0 -Pcassandra-spark-1.5   -Dhbase.hbase.version=1.1.8 -Pspark-2.1 -Phadoop-2.7 -Pyarn -Ppyspark -Psparkr -Pscala-2.11
>
>
> ERROR RECEIVED
> Java HotSpot(TM) 64-Bit Server VM warning: ignoring option MaxPermSize=1024m; support was removed in 8.0
> [INFO] Scanning for projects...
> Downloading: https://repo.maven.apache.org/maven2/org/apache/apache/17/apache-17.pom
> [ERROR] [ERROR] Some problems were encountered while processing the POMs:
> [FATAL] Non-resolvable parent POM for org.apache.zeppelin:zeppelin:0.8.0-SNAPSHOT: Could not transfer artifact org.apache:apache:pom:17 from/to central (https://repo.maven.apache.org/maven2): repo.maven.apache.org: Name or service not known and 'parent.relativePath' points at wrong local POM @ line 32, column 11
> @
> [ERROR] The build could not read 1 project -> [Help 1]
> [ERROR]  
> [ERROR]   The project org.apache.zeppelin:zeppelin:0.8.0-SNAPSHOT (/opt/zeppelin/zeppelin/pom.xml) has 1 error
> [ERROR]     Non-resolvable parent POM for org.apache.zeppelin:zeppelin:0.8.0-SNAPSHOT: Could not transfer artifact org.apache:apache:pom:17 from/to central (https://repo.maven.apache.org/maven2): repo.maven.apache.org: Name or service not known and 'parent.relativePath' points at wrong local POM @ line 32, column 11: Unknown host repo.maven.apache.org: Name or service not known -> [Help 2]
> [ERROR]
> [ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
> [ERROR] Re-run Maven using the -X switch to enable full debug logging.
> [ERROR]
> [ERROR] For more information about the errors and possible solutions, please read the following articles:
> [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/ProjectBuildingException
> [ERROR] [Help 2] http://cwiki.apache.org/confluence/display/MAVEN/UnresolvableModelException
>

Reply | Threaded
Open this post in threaded view
|

Re: Building Zeppelin on Mapr 5.2 MEP 3.0 Fails with error below

ligaroba@gmail.com
Hi Michael,
What issues did you face?

From tutorials zeppelin is built on hbase 1.0.x but I want it to use hbase 1.1.8  



What should I use in place of 0.8.0 in the case of 0.7.2?


On Oct 19, 2017 15:55, "Michael Segel" <[hidden email]> wrote:
Hi,

Why are you using  -Pmapr50 instead of -Pmapr51  (There is no 5.2)

You’re building against 0.8.0 which isn’t the latest ‘stable’ release.

I’ve had issues building a MapR release against 7.3 but could build against 7.2
(Albeit I’ve had some issues along the way.)

Also why the added HBase?

Is there any reason why you couldn’t go back to 7.2 and try that release?

> On Oct 19, 2017, at 4:44 AM, [hidden email] wrote:
>
> Hi Am building zeppelin on mapr 5.2 MEP 3.0
> COMMAND USED
> mvn clean package -DskipTests -Pmapr50 -Pscalding -Dignite.version=1.9.0 -Pcassandra-spark-1.5   -Dhbase.hbase.version=1.1.8 -Pspark-2.1 -Phadoop-2.7 -Pyarn -Ppyspark -Psparkr -Pscala-2.11
>
>
> ERROR RECEIVED
> Java HotSpot(TM) 64-Bit Server VM warning: ignoring option MaxPermSize=1024m; support was removed in 8.0
> [INFO] Scanning for projects...
> Downloading: https://repo.maven.apache.org/maven2/org/apache/apache/17/apache-17.pom
> [ERROR] [ERROR] Some problems were encountered while processing the POMs:
> [FATAL] Non-resolvable parent POM for org.apache.zeppelin:zeppelin:0.8.0-SNAPSHOT: Could not transfer artifact org.apache:apache:pom:17 from/to central (https://repo.maven.apache.org/maven2): repo.maven.apache.org: Name or service not known and 'parent.relativePath' points at wrong local POM @ line 32, column 11
> @
> [ERROR] The build could not read 1 project -> [Help 1]
> [ERROR]
> [ERROR]   The project org.apache.zeppelin:zeppelin:0.8.0-SNAPSHOT (/opt/zeppelin/zeppelin/pom.xml) has 1 error
> [ERROR]     Non-resolvable parent POM for org.apache.zeppelin:zeppelin:0.8.0-SNAPSHOT: Could not transfer artifact org.apache:apache:pom:17 from/to central (https://repo.maven.apache.org/maven2): repo.maven.apache.org: Name or service not known and 'parent.relativePath' points at wrong local POM @ line 32, column 11: Unknown host repo.maven.apache.org: Name or service not known -> [Help 2]
> [ERROR]
> [ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
> [ERROR] Re-run Maven using the -X switch to enable full debug logging.
> [ERROR]
> [ERROR] For more information about the errors and possible solutions, please read the following articles:
> [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/ProjectBuildingException
> [ERROR] [Help 2] http://cwiki.apache.org/confluence/display/MAVEN/UnresolvableModelException
>


Reply | Threaded
Open this post in threaded view
|

Re: Building Zeppelin on Mapr 5.2 MEP 3.0 Fails with error below

Michael Segel
I had issues where the build dies at Flink when I tried to build it against 0.7.3 no idea why the build failed and I don’t have time to focus on it at the moment. (7.2 works well enough for me right now.) 

I spoke with a contact at MapR and she suggested going back to 0.7.2 . 
I’ve seen a couple of the MapR blogs on Zeppelin and Mathieu had said he was able to build against 0.8.0 however since its not the stable release, but the latest, YMMV. 

I believe if you’re planning on using Drill, then you will want the 0.7.2 release. 

I’m not planning on using HBase and I think you can use the default value if you’re planning on using MapR-DB

It looks like you’re also using Casandra and a few other packages which I’m not using. 

I am a firm believer of KISS (Keep it simple stupid) so I suggest starting simple and expanding out. 
The nice thing … you can always recompile /build and not lose your configuration and just restart. 

HTH

-Mike

PS. In my current work, I’m running spark as stand alone on my single node ‘cluster’ with the data on the MapRFS.  (I hate YARN) ;-)  Again, YMMV


On Oct 19, 2017, at 1:41 PM, ligaye robert <[hidden email]> wrote:

Hi Michael,
What issues did you face?

From tutorials zeppelin is built on hbase 1.0.x but I want it to use hbase 1.1.8  



What should I use in place of 0.8.0 in the case of 0.7.2?


On Oct 19, 2017 15:55, "Michael Segel" <[hidden email]> wrote:
Hi,

Why are you using  -Pmapr50 instead of -Pmapr51  (There is no 5.2)

You’re building against 0.8.0 which isn’t the latest ‘stable’ release.

I’ve had issues building a MapR release against 7.3 but could build against 7.2
(Albeit I’ve had some issues along the way.)

Also why the added HBase?

Is there any reason why you couldn’t go back to 7.2 and try that release?

> On Oct 19, 2017, at 4:44 AM, [hidden email] wrote:
>
> Hi Am building zeppelin on mapr 5.2 MEP 3.0
> COMMAND USED
> mvn clean package -DskipTests -Pmapr50 -Pscalding -Dignite.version=1.9.0 -Pcassandra-spark-1.5   -Dhbase.hbase.version=1.1.8 -Pspark-2.1 -Phadoop-2.7 -Pyarn -Ppyspark -Psparkr -Pscala-2.11
>
>
> ERROR RECEIVED
> Java HotSpot(TM) 64-Bit Server VM warning: ignoring option MaxPermSize=1024m; support was removed in 8.0
> [INFO] Scanning for projects...
> Downloading: https://repo.maven.apache.org/maven2/org/apache/apache/17/apache-17.pom
> [ERROR] [ERROR] Some problems were encountered while processing the POMs:
> [FATAL] Non-resolvable parent POM for org.apache.zeppelin:zeppelin:0.8.0-SNAPSHOT: Could not transfer artifact org.apache:apache:pom:17 from/to central (https://repo.maven.apache.org/maven2): repo.maven.apache.org: Name or service not known and 'parent.relativePath' points at wrong local POM @ line 32, column 11
> @
> [ERROR] The build could not read 1 project -> [Help 1]
> [ERROR]
> [ERROR]   The project org.apache.zeppelin:zeppelin:0.8.0-SNAPSHOT (/opt/zeppelin/zeppelin/pom.xml) has 1 error
> [ERROR]     Non-resolvable parent POM for org.apache.zeppelin:zeppelin:0.8.0-SNAPSHOT: Could not transfer artifact org.apache:apache:pom:17 from/to central (https://repo.maven.apache.org/maven2): repo.maven.apache.org: Name or service not known and 'parent.relativePath' points at wrong local POM @ line 32, column 11: Unknown host repo.maven.apache.org: Name or service not known -> [Help 2]
> [ERROR]
> [ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
> [ERROR] Re-run Maven using the -X switch to enable full debug logging.
> [ERROR]
> [ERROR] For more information about the errors and possible solutions, please read the following articles:
> [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/ProjectBuildingException
> [ERROR] [Help 2] http://cwiki.apache.org/confluence/display/MAVEN/UnresolvableModelException
>



Reply | Threaded
Open this post in threaded view
|

Re: Building Zeppelin on Mapr 5.2 MEP 3.0 Fails with error below

ligaroba@gmail.com
Thanks 
So how was your configuration like I mean the maven artifacts for 0.7.2 could you share? What should I replace with in the current 0.8.0 in the pom.xml?

On Oct 19, 2017 22:01, "Michael Segel" <[hidden email]> wrote:
I had issues where the build dies at Flink when I tried to build it against 0.7.3 no idea why the build failed and I don’t have time to focus on it at the moment. (7.2 works well enough for me right now.) 

I spoke with a contact at MapR and she suggested going back to 0.7.2 . 
I’ve seen a couple of the MapR blogs on Zeppelin and Mathieu had said he was able to build against 0.8.0 however since its not the stable release, but the latest, YMMV. 

I believe if you’re planning on using Drill, then you will want the 0.7.2 release. 

I’m not planning on using HBase and I think you can use the default value if you’re planning on using MapR-DB

It looks like you’re also using Casandra and a few other packages which I’m not using. 

I am a firm believer of KISS (Keep it simple stupid) so I suggest starting simple and expanding out. 
The nice thing … you can always recompile /build and not lose your configuration and just restart. 

HTH

-Mike

PS. In my current work, I’m running spark as stand alone on my single node ‘cluster’ with the data on the MapRFS.  (I hate YARN) ;-)  Again, YMMV


On Oct 19, 2017, at 1:41 PM, ligaye robert <[hidden email]> wrote:

Hi Michael,
What issues did you face?

From tutorials zeppelin is built on hbase 1.0.x but I want it to use hbase 1.1.8  



What should I use in place of 0.8.0 in the case of 0.7.2?


On Oct 19, 2017 15:55, "Michael Segel" <[hidden email]> wrote:
Hi,

Why are you using  -Pmapr50 instead of -Pmapr51  (There is no 5.2)

You’re building against 0.8.0 which isn’t the latest ‘stable’ release.

I’ve had issues building a MapR release against 7.3 but could build against 7.2
(Albeit I’ve had some issues along the way.)

Also why the added HBase?

Is there any reason why you couldn’t go back to 7.2 and try that release?

> On Oct 19, 2017, at 4:44 AM, [hidden email] wrote:
>
> Hi Am building zeppelin on mapr 5.2 MEP 3.0
> COMMAND USED
> mvn clean package -DskipTests -Pmapr50 -Pscalding -Dignite.version=1.9.0 -Pcassandra-spark-1.5   -Dhbase.hbase.version=1.1.8 -Pspark-2.1 -Phadoop-2.7 -Pyarn -Ppyspark -Psparkr -Pscala-2.11
>
>
> ERROR RECEIVED
> Java HotSpot(TM) 64-Bit Server VM warning: ignoring option MaxPermSize=1024m; support was removed in 8.0
> [INFO] Scanning for projects...
> Downloading: https://repo.maven.apache.org/maven2/org/apache/apache/17/apache-17.pom
> [ERROR] [ERROR] Some problems were encountered while processing the POMs:
> [FATAL] Non-resolvable parent POM for org.apache.zeppelin:zeppelin:0.8.0-SNAPSHOT: Could not transfer artifact org.apache:apache:pom:17 from/to central (https://repo.maven.apache.org/maven2): repo.maven.apache.org: Name or service not known and 'parent.relativePath' points at wrong local POM @ line 32, column 11
> @
> [ERROR] The build could not read 1 project -> [Help 1]
> [ERROR]
> [ERROR]   The project org.apache.zeppelin:zeppelin:0.8.0-SNAPSHOT (/opt/zeppelin/zeppelin/pom.xml) has 1 error
> [ERROR]     Non-resolvable parent POM for org.apache.zeppelin:zeppelin:0.8.0-SNAPSHOT: Could not transfer artifact org.apache:apache:pom:17 from/to central (https://repo.maven.apache.org/maven2): repo.maven.apache.org: Name or service not known and 'parent.relativePath' points at wrong local POM @ line 32, column 11: Unknown host repo.maven.apache.org: Name or service not known -> [Help 2]
> [ERROR]
> [ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
> [ERROR] Re-run Maven using the -X switch to enable full debug logging.
> [ERROR]
> [ERROR] For more information about the errors and possible solutions, please read the following articles:
> [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/ProjectBuildingException
> [ERROR] [Help 2] http://cwiki.apache.org/confluence/display/MAVEN/UnresolvableModelException
>



Reply | Threaded
Open this post in threaded view
|

Re: Building Zeppelin on Mapr 5.2 MEP 3.0 Fails with error below

Michael Segel
I wouldn’t use the 0.7.2 pom with 0.8.0 source. 

If you go to the MapR Community site, you can search for anything Zeppelin related and there are a couple of articles that contain the parameters used in the build. 

On Oct 19, 2017, at 9:24 PM, ligaye robert <[hidden email]> wrote:

Thanks 
So how was your configuration like I mean the maven artifacts for 0.7.2 could you share? What should I replace with in the current 0.8.0 in the pom.xml?

On Oct 19, 2017 22:01, "Michael Segel" <[hidden email]> wrote:
I had issues where the build dies at Flink when I tried to build it against 0.7.3 no idea why the build failed and I don’t have time to focus on it at the moment. (7.2 works well enough for me right now.) 

I spoke with a contact at MapR and she suggested going back to 0.7.2 . 
I’ve seen a couple of the MapR blogs on Zeppelin and Mathieu had said he was able to build against 0.8.0 however since its not the stable release, but the latest, YMMV. 

I believe if you’re planning on using Drill, then you will want the 0.7.2 release. 

I’m not planning on using HBase and I think you can use the default value if you’re planning on using MapR-DB

It looks like you’re also using Casandra and a few other packages which I’m not using. 

I am a firm believer of KISS (Keep it simple stupid) so I suggest starting simple and expanding out. 
The nice thing … you can always recompile /build and not lose your configuration and just restart. 

HTH

-Mike

PS. In my current work, I’m running spark as stand alone on my single node ‘cluster’ with the data on the MapRFS.  (I hate YARN) ;-)  Again, YMMV


On Oct 19, 2017, at 1:41 PM, ligaye robert <[hidden email]> wrote:

Hi Michael,
What issues did you face?

From tutorials zeppelin is built on hbase 1.0.x but I want it to use hbase 1.1.8  



What should I use in place of 0.8.0 in the case of 0.7.2?


On Oct 19, 2017 15:55, "Michael Segel" <[hidden email]> wrote:
Hi,

Why are you using  -Pmapr50 instead of -Pmapr51  (There is no 5.2)

You’re building against 0.8.0 which isn’t the latest ‘stable’ release.

I’ve had issues building a MapR release against 7.3 but could build against 7.2
(Albeit I’ve had some issues along the way.)

Also why the added HBase?

Is there any reason why you couldn’t go back to 7.2 and try that release?

> On Oct 19, 2017, at 4:44 AM, [hidden email] wrote:
>
> Hi Am building zeppelin on mapr 5.2 MEP 3.0
> COMMAND USED
> mvn clean package -DskipTests -Pmapr50 -Pscalding -Dignite.version=1.9.0 -Pcassandra-spark-1.5   -Dhbase.hbase.version=1.1.8 -Pspark-2.1 -Phadoop-2.7 -Pyarn -Ppyspark -Psparkr -Pscala-2.11
>
>
> ERROR RECEIVED
> Java HotSpot(TM) 64-Bit Server VM warning: ignoring option MaxPermSize=1024m; support was removed in 8.0
> [INFO] Scanning for projects...
> Downloading: https://repo.maven.apache.org/maven2/org/apache/apache/17/apache-17.pom
> [ERROR] [ERROR] Some problems were encountered while processing the POMs:
> [FATAL] Non-resolvable parent POM for org.apache.zeppelin:zeppelin:0.8.0-SNAPSHOT: Could not transfer artifact org.apache:apache:pom:17 from/to central (https://repo.maven.apache.org/maven2): repo.maven.apache.org: Name or service not known and 'parent.relativePath' points at wrong local POM @ line 32, column 11
> @
> [ERROR] The build could not read 1 project -> [Help 1]
> [ERROR]
> [ERROR]   The project org.apache.zeppelin:zeppelin:0.8.0-SNAPSHOT (/opt/zeppelin/zeppelin/pom.xml) has 1 error
> [ERROR]     Non-resolvable parent POM for org.apache.zeppelin:zeppelin:0.8.0-SNAPSHOT: Could not transfer artifact org.apache:apache:pom:17 from/to central (https://repo.maven.apache.org/maven2): repo.maven.apache.org: Name or service not known and 'parent.relativePath' points at wrong local POM @ line 32, column 11: Unknown host repo.maven.apache.org: Name or service not known -> [Help 2]
> [ERROR]
> [ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
> [ERROR] Re-run Maven using the -X switch to enable full debug logging.
> [ERROR]
> [ERROR] For more information about the errors and possible solutions, please read the following articles:
> [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/ProjectBuildingException
> [ERROR] [Help 2] http://cwiki.apache.org/confluence/display/MAVEN/UnresolvableModelException
>