Build from source assistance: web Application fails on "required class missing"

classic Classic list List threaded Threaded
10 messages Options
Reply | Threaded
Open this post in threaded view
|

Build from source assistance: web Application fails on "required class missing"

Stephen Boesch
I have cloned from git and run:

   mvn clean package -DskipTests

The core and engine build but the web Application does not:


INFO] Reactor Summary:
[INFO]
[INFO] Zeppelin ........................................... SUCCESS [  1.274 s]
[INFO] Zeppelin: Zengine .................................. SUCCESS [  2.554 s]
[INFO] Zeppelin: Spark .................................... SUCCESS [  3.773 s]
[INFO] Zeppelin: Markdown interpreter ..................... SUCCESS [  0.128 s]
[INFO] Zeppelin: Shell interpreter ........................ SUCCESS [  0.097 s]
[INFO] Zeppelin: web Application .......................... FAILURE [  0.172 s]


[ERROR] Failed to execute goal com.github.eirslett:frontend-maven-plugin:0.0.16:install-node-and-npm (install node and npm) on project zeppelin-web: Execution install node and npm of goal com.github.eirslett:frontend-maven-plugin:0.0.16:install-node-and-npm failed: A required class was missing while executing com.github.eirslett:frontend-maven-plugin:0.0.16:install-node-and-npm: org/slf4j/helpers/MarkerIgnoringBase
[ERROR] -----------------------------------------------------
[ERROR] realm =    plugin>com.github.eirslett:frontend-maven-plugin:0.0.16
[ERROR] strategy = org.codehaus.plexus.classworlds.strategy.SelfFirstStrategy


So how to build this?

Reply | Threaded
Open this post in threaded view
|

Re: Build from source assistance: web Application fails on "required class missing"

moon
Administrator
Could you share your OS and maven version?

Thanks,
moon

On Mon, Oct 12, 2015 at 4:39 PM Stephen Boesch <[hidden email]> wrote:
I have cloned from git and run:

   mvn clean package -DskipTests

The core and engine build but the web Application does not:


INFO] Reactor Summary:
[INFO]
[INFO] Zeppelin ........................................... SUCCESS [  1.274 s]
[INFO] Zeppelin: Zengine .................................. SUCCESS [  2.554 s]
[INFO] Zeppelin: Spark .................................... SUCCESS [  3.773 s]
[INFO] Zeppelin: Markdown interpreter ..................... SUCCESS [  0.128 s]
[INFO] Zeppelin: Shell interpreter ........................ SUCCESS [  0.097 s]
[INFO] Zeppelin: web Application .......................... FAILURE [  0.172 s]


[ERROR] Failed to execute goal com.github.eirslett:frontend-maven-plugin:0.0.16:install-node-and-npm (install node and npm) on project zeppelin-web: Execution install node and npm of goal com.github.eirslett:frontend-maven-plugin:0.0.16:install-node-and-npm failed: A required class was missing while executing com.github.eirslett:frontend-maven-plugin:0.0.16:install-node-and-npm: org/slf4j/helpers/MarkerIgnoringBase
[ERROR] -----------------------------------------------------
[ERROR] realm =    plugin>com.github.eirslett:frontend-maven-plugin:0.0.16
[ERROR] strategy = org.codehaus.plexus.classworlds.strategy.SelfFirstStrategy


So how to build this?

Reply | Threaded
Open this post in threaded view
|

Re: Build from source assistance: web Application fails on "required class missing"

Stephen Boesch
os/x yosemite  and maven 3.3.3

2015-10-13 1:06 GMT-07:00 moon soo Lee <[hidden email]>:
Could you share your OS and maven version?

Thanks,
moon

On Mon, Oct 12, 2015 at 4:39 PM Stephen Boesch <[hidden email]> wrote:
I have cloned from git and run:

   mvn clean package -DskipTests

The core and engine build but the web Application does not:


INFO] Reactor Summary:
[INFO]
[INFO] Zeppelin ........................................... SUCCESS [  1.274 s]
[INFO] Zeppelin: Zengine .................................. SUCCESS [  2.554 s]
[INFO] Zeppelin: Spark .................................... SUCCESS [  3.773 s]
[INFO] Zeppelin: Markdown interpreter ..................... SUCCESS [  0.128 s]
[INFO] Zeppelin: Shell interpreter ........................ SUCCESS [  0.097 s]
[INFO] Zeppelin: web Application .......................... FAILURE [  0.172 s]


[ERROR] Failed to execute goal com.github.eirslett:frontend-maven-plugin:0.0.16:install-node-and-npm (install node and npm) on project zeppelin-web: Execution install node and npm of goal com.github.eirslett:frontend-maven-plugin:0.0.16:install-node-and-npm failed: A required class was missing while executing com.github.eirslett:frontend-maven-plugin:0.0.16:install-node-and-npm: org/slf4j/helpers/MarkerIgnoringBase
[ERROR] -----------------------------------------------------
[ERROR] realm =    plugin>com.github.eirslett:frontend-maven-plugin:0.0.16
[ERROR] strategy = org.codehaus.plexus.classworlds.strategy.SelfFirstStrategy


So how to build this?


Reply | Threaded
Open this post in threaded view
|

Re: Build from source assistance: web Application fails on "required class missing"

moon
Administrator
I'm using os/x yosemite and maven 3.3.3, too and i have no problem building zeppelin-web module.

Here's related issue https://github.com/eirslett/frontend-maven-plugin/issues/179. The issue is resolved and Zeppelin uses 0.0.23 version which is version with the fix. 

Can someone also help to try build zeppelin-web module if you have os/x and maven 3.3.3?

Thanks,
moon

On Tue, Oct 13, 2015 at 10:57 AM Stephen Boesch <[hidden email]> wrote:
os/x yosemite  and maven 3.3.3

2015-10-13 1:06 GMT-07:00 moon soo Lee <[hidden email]>:
Could you share your OS and maven version?

Thanks,
moon

On Mon, Oct 12, 2015 at 4:39 PM Stephen Boesch <[hidden email]> wrote:
I have cloned from git and run:

   mvn clean package -DskipTests

The core and engine build but the web Application does not:


INFO] Reactor Summary:
[INFO]
[INFO] Zeppelin ........................................... SUCCESS [  1.274 s]
[INFO] Zeppelin: Zengine .................................. SUCCESS [  2.554 s]
[INFO] Zeppelin: Spark .................................... SUCCESS [  3.773 s]
[INFO] Zeppelin: Markdown interpreter ..................... SUCCESS [  0.128 s]
[INFO] Zeppelin: Shell interpreter ........................ SUCCESS [  0.097 s]
[INFO] Zeppelin: web Application .......................... FAILURE [  0.172 s]


[ERROR] Failed to execute goal com.github.eirslett:frontend-maven-plugin:0.0.16:install-node-and-npm (install node and npm) on project zeppelin-web: Execution install node and npm of goal com.github.eirslett:frontend-maven-plugin:0.0.16:install-node-and-npm failed: A required class was missing while executing com.github.eirslett:frontend-maven-plugin:0.0.16:install-node-and-npm: org/slf4j/helpers/MarkerIgnoringBase
[ERROR] -----------------------------------------------------
[ERROR] realm =    plugin>com.github.eirslett:frontend-maven-plugin:0.0.16
[ERROR] strategy = org.codehaus.plexus.classworlds.strategy.SelfFirstStrategy


So how to build this?


Reply | Threaded
Open this post in threaded view
|

Re: Build from source assistance: web Application fails on "required class missing"

Ranveer Kumar-2

I am also using os x and maven 3.3.3 and found no issue.  Please try again as sometimes it gives issue but trying again will resolve issue.


On Tue, 13 Oct 2015 14:51 moon soo Lee <[hidden email]> wrote:
I'm using os/x yosemite and maven 3.3.3, too and i have no problem building zeppelin-web module.

Here's related issue https://github.com/eirslett/frontend-maven-plugin/issues/179. The issue is resolved and Zeppelin uses 0.0.23 version which is version with the fix. 

Can someone also help to try build zeppelin-web module if you have os/x and maven 3.3.3?

Thanks,
moon

On Tue, Oct 13, 2015 at 10:57 AM Stephen Boesch <[hidden email]> wrote:
os/x yosemite  and maven 3.3.3

2015-10-13 1:06 GMT-07:00 moon soo Lee <[hidden email]>:
Could you share your OS and maven version?

Thanks,
moon

On Mon, Oct 12, 2015 at 4:39 PM Stephen Boesch <[hidden email]> wrote:
I have cloned from git and run:

   mvn clean package -DskipTests

The core and engine build but the web Application does not:


INFO] Reactor Summary:
[INFO]
[INFO] Zeppelin ........................................... SUCCESS [  1.274 s]
[INFO] Zeppelin: Zengine .................................. SUCCESS [  2.554 s]
[INFO] Zeppelin: Spark .................................... SUCCESS [  3.773 s]
[INFO] Zeppelin: Markdown interpreter ..................... SUCCESS [  0.128 s]
[INFO] Zeppelin: Shell interpreter ........................ SUCCESS [  0.097 s]
[INFO] Zeppelin: web Application .......................... FAILURE [  0.172 s]


[ERROR] Failed to execute goal com.github.eirslett:frontend-maven-plugin:0.0.16:install-node-and-npm (install node and npm) on project zeppelin-web: Execution install node and npm of goal com.github.eirslett:frontend-maven-plugin:0.0.16:install-node-and-npm failed: A required class was missing while executing com.github.eirslett:frontend-maven-plugin:0.0.16:install-node-and-npm: org/slf4j/helpers/MarkerIgnoringBase
[ERROR] -----------------------------------------------------
[ERROR] realm =    plugin>com.github.eirslett:frontend-maven-plugin:0.0.16
[ERROR] strategy = org.codehaus.plexus.classworlds.strategy.SelfFirstStrategy


So how to build this?


Reply | Threaded
Open this post in threaded view
|

Re: Build from source assistance: web Application fails on "required class missing"

Corneau Damien
In reply to this post by moon

Zeppelin is supposed to use 0.0.23, but your logs are showing 0.0.16

On Oct 13, 2015 6:21 PM, "moon soo Lee" <[hidden email]> wrote:
I'm using os/x yosemite and maven 3.3.3, too and i have no problem building zeppelin-web module.

Here's related issue https://github.com/eirslett/frontend-maven-plugin/issues/179. The issue is resolved and Zeppelin uses 0.0.23 version which is version with the fix. 

Can someone also help to try build zeppelin-web module if you have os/x and maven 3.3.3?

Thanks,
moon

On Tue, Oct 13, 2015 at 10:57 AM Stephen Boesch <[hidden email]> wrote:
os/x yosemite  and maven 3.3.3

2015-10-13 1:06 GMT-07:00 moon soo Lee <[hidden email]>:
Could you share your OS and maven version?

Thanks,
moon

On Mon, Oct 12, 2015 at 4:39 PM Stephen Boesch <[hidden email]> wrote:
I have cloned from git and run:

   mvn clean package -DskipTests

The core and engine build but the web Application does not:


INFO] Reactor Summary:
[INFO]
[INFO] Zeppelin ........................................... SUCCESS [  1.274 s]
[INFO] Zeppelin: Zengine .................................. SUCCESS [  2.554 s]
[INFO] Zeppelin: Spark .................................... SUCCESS [  3.773 s]
[INFO] Zeppelin: Markdown interpreter ..................... SUCCESS [  0.128 s]
[INFO] Zeppelin: Shell interpreter ........................ SUCCESS [  0.097 s]
[INFO] Zeppelin: web Application .......................... FAILURE [  0.172 s]


[ERROR] Failed to execute goal com.github.eirslett:frontend-maven-plugin:0.0.16:install-node-and-npm (install node and npm) on project zeppelin-web: Execution install node and npm of goal com.github.eirslett:frontend-maven-plugin:0.0.16:install-node-and-npm failed: A required class was missing while executing com.github.eirslett:frontend-maven-plugin:0.0.16:install-node-and-npm: org/slf4j/helpers/MarkerIgnoringBase
[ERROR] -----------------------------------------------------
[ERROR] realm =    plugin>com.github.eirslett:frontend-maven-plugin:0.0.16
[ERROR] strategy = org.codehaus.plexus.classworlds.strategy.SelfFirstStrategy


So how to build this?


Reply | Threaded
Open this post in threaded view
|

Re: Build from source assistance: web Application fails on "required class missing"

Stephen Boesch
I have made no change to the build: this is a clean install from git sources.  So the comment about zeppelin to use 0.0.23 vs 0.0.16 .. the question is : why  is the build selecting that version. I have made no customizations. 

re:  "try again":  I have tried to build this a few times before venturing to contact the mailing list.

2015-10-13 2:31 GMT-07:00 Corneau Damien <[hidden email]>:

Zeppelin is supposed to use 0.0.23, but your logs are showing 0.0.16

On Oct 13, 2015 6:21 PM, "moon soo Lee" <[hidden email]> wrote:
I'm using os/x yosemite and maven 3.3.3, too and i have no problem building zeppelin-web module.

Here's related issue https://github.com/eirslett/frontend-maven-plugin/issues/179. The issue is resolved and Zeppelin uses 0.0.23 version which is version with the fix. 

Can someone also help to try build zeppelin-web module if you have os/x and maven 3.3.3?

Thanks,
moon

On Tue, Oct 13, 2015 at 10:57 AM Stephen Boesch <[hidden email]> wrote:
os/x yosemite  and maven 3.3.3

2015-10-13 1:06 GMT-07:00 moon soo Lee <[hidden email]>:
Could you share your OS and maven version?

Thanks,
moon

On Mon, Oct 12, 2015 at 4:39 PM Stephen Boesch <[hidden email]> wrote:
I have cloned from git and run:

   mvn clean package -DskipTests

The core and engine build but the web Application does not:


INFO] Reactor Summary:
[INFO]
[INFO] Zeppelin ........................................... SUCCESS [  1.274 s]
[INFO] Zeppelin: Zengine .................................. SUCCESS [  2.554 s]
[INFO] Zeppelin: Spark .................................... SUCCESS [  3.773 s]
[INFO] Zeppelin: Markdown interpreter ..................... SUCCESS [  0.128 s]
[INFO] Zeppelin: Shell interpreter ........................ SUCCESS [  0.097 s]
[INFO] Zeppelin: web Application .......................... FAILURE [  0.172 s]


[ERROR] Failed to execute goal com.github.eirslett:frontend-maven-plugin:0.0.16:install-node-and-npm (install node and npm) on project zeppelin-web: Execution install node and npm of goal com.github.eirslett:frontend-maven-plugin:0.0.16:install-node-and-npm failed: A required class was missing while executing com.github.eirslett:frontend-maven-plugin:0.0.16:install-node-and-npm: org/slf4j/helpers/MarkerIgnoringBase
[ERROR] -----------------------------------------------------
[ERROR] realm =    plugin>com.github.eirslett:frontend-maven-plugin:0.0.16
[ERROR] strategy = org.codehaus.plexus.classworlds.strategy.SelfFirstStrategy


So how to build this?



Reply | Threaded
Open this post in threaded view
|

Re: Build from source assistance: web Application fails on "required class missing"

Corneau Damien
Can you try cleaning your ~/.m2 directory?

On Tue, Oct 13, 2015 at 6:35 PM, Stephen Boesch <[hidden email]> wrote:
I have made no change to the build: this is a clean install from git sources.  So the comment about zeppelin to use 0.0.23 vs 0.0.16 .. the question is : why  is the build selecting that version. I have made no customizations. 

re:  "try again":  I have tried to build this a few times before venturing to contact the mailing list.

2015-10-13 2:31 GMT-07:00 Corneau Damien <[hidden email]>:

Zeppelin is supposed to use 0.0.23, but your logs are showing 0.0.16

On Oct 13, 2015 6:21 PM, "moon soo Lee" <[hidden email]> wrote:
I'm using os/x yosemite and maven 3.3.3, too and i have no problem building zeppelin-web module.

Here's related issue https://github.com/eirslett/frontend-maven-plugin/issues/179. The issue is resolved and Zeppelin uses 0.0.23 version which is version with the fix. 

Can someone also help to try build zeppelin-web module if you have os/x and maven 3.3.3?

Thanks,
moon

On Tue, Oct 13, 2015 at 10:57 AM Stephen Boesch <[hidden email]> wrote:
os/x yosemite  and maven 3.3.3

2015-10-13 1:06 GMT-07:00 moon soo Lee <[hidden email]>:
Could you share your OS and maven version?

Thanks,
moon

On Mon, Oct 12, 2015 at 4:39 PM Stephen Boesch <[hidden email]> wrote:
I have cloned from git and run:

   mvn clean package -DskipTests

The core and engine build but the web Application does not:


INFO] Reactor Summary:
[INFO]
[INFO] Zeppelin ........................................... SUCCESS [  1.274 s]
[INFO] Zeppelin: Zengine .................................. SUCCESS [  2.554 s]
[INFO] Zeppelin: Spark .................................... SUCCESS [  3.773 s]
[INFO] Zeppelin: Markdown interpreter ..................... SUCCESS [  0.128 s]
[INFO] Zeppelin: Shell interpreter ........................ SUCCESS [  0.097 s]
[INFO] Zeppelin: web Application .......................... FAILURE [  0.172 s]


[ERROR] Failed to execute goal com.github.eirslett:frontend-maven-plugin:0.0.16:install-node-and-npm (install node and npm) on project zeppelin-web: Execution install node and npm of goal com.github.eirslett:frontend-maven-plugin:0.0.16:install-node-and-npm failed: A required class was missing while executing com.github.eirslett:frontend-maven-plugin:0.0.16:install-node-and-npm: org/slf4j/helpers/MarkerIgnoringBase
[ERROR] -----------------------------------------------------
[ERROR] realm =    plugin>com.github.eirslett:frontend-maven-plugin:0.0.16
[ERROR] strategy = org.codehaus.plexus.classworlds.strategy.SelfFirstStrategy


So how to build this?




Reply | Threaded
Open this post in threaded view
|

Re: Build from source assistance: web Application fails on "required class missing"

Stephen Boesch
It was 'my bad':   the problem was a mistake of mine with git. I use git fetch upstream and then git rebase as the process. This time I just neglected to do the second step.  Corneau's tip about 0.16 vs 0.23 made me suspicious of the seetup.

thanks for the help.

2015-10-13 5:12 GMT-07:00 Corneau Damien <[hidden email]>:
Can you try cleaning your ~/.m2 directory?

On Tue, Oct 13, 2015 at 6:35 PM, Stephen Boesch <[hidden email]> wrote:
I have made no change to the build: this is a clean install from git sources.  So the comment about zeppelin to use 0.0.23 vs 0.0.16 .. the question is : why  is the build selecting that version. I have made no customizations. 

re:  "try again":  I have tried to build this a few times before venturing to contact the mailing list.

2015-10-13 2:31 GMT-07:00 Corneau Damien <[hidden email]>:

Zeppelin is supposed to use 0.0.23, but your logs are showing 0.0.16

On Oct 13, 2015 6:21 PM, "moon soo Lee" <[hidden email]> wrote:
I'm using os/x yosemite and maven 3.3.3, too and i have no problem building zeppelin-web module.

Here's related issue https://github.com/eirslett/frontend-maven-plugin/issues/179. The issue is resolved and Zeppelin uses 0.0.23 version which is version with the fix. 

Can someone also help to try build zeppelin-web module if you have os/x and maven 3.3.3?

Thanks,
moon

On Tue, Oct 13, 2015 at 10:57 AM Stephen Boesch <[hidden email]> wrote:
os/x yosemite  and maven 3.3.3

2015-10-13 1:06 GMT-07:00 moon soo Lee <[hidden email]>:
Could you share your OS and maven version?

Thanks,
moon

On Mon, Oct 12, 2015 at 4:39 PM Stephen Boesch <[hidden email]> wrote:
I have cloned from git and run:

   mvn clean package -DskipTests

The core and engine build but the web Application does not:


INFO] Reactor Summary:
[INFO]
[INFO] Zeppelin ........................................... SUCCESS [  1.274 s]
[INFO] Zeppelin: Zengine .................................. SUCCESS [  2.554 s]
[INFO] Zeppelin: Spark .................................... SUCCESS [  3.773 s]
[INFO] Zeppelin: Markdown interpreter ..................... SUCCESS [  0.128 s]
[INFO] Zeppelin: Shell interpreter ........................ SUCCESS [  0.097 s]
[INFO] Zeppelin: web Application .......................... FAILURE [  0.172 s]


[ERROR] Failed to execute goal com.github.eirslett:frontend-maven-plugin:0.0.16:install-node-and-npm (install node and npm) on project zeppelin-web: Execution install node and npm of goal com.github.eirslett:frontend-maven-plugin:0.0.16:install-node-and-npm failed: A required class was missing while executing com.github.eirslett:frontend-maven-plugin:0.0.16:install-node-and-npm: org/slf4j/helpers/MarkerIgnoringBase
[ERROR] -----------------------------------------------------
[ERROR] realm =    plugin>com.github.eirslett:frontend-maven-plugin:0.0.16
[ERROR] strategy = org.codehaus.plexus.classworlds.strategy.SelfFirstStrategy


So how to build this?





Reply | Threaded
Open this post in threaded view
|

Re: Build from source assistance: web Application fails on "required class missing"

Corneau Damien

Good to know.
Post again if you have orher problems or questions.

On Oct 14, 2015 12:27 AM, "Stephen Boesch" <[hidden email]> wrote:
It was 'my bad':   the problem was a mistake of mine with git. I use git fetch upstream and then git rebase as the process. This time I just neglected to do the second step.  Corneau's tip about 0.16 vs 0.23 made me suspicious of the seetup.

thanks for the help.

2015-10-13 5:12 GMT-07:00 Corneau Damien <[hidden email]>:
Can you try cleaning your ~/.m2 directory?

On Tue, Oct 13, 2015 at 6:35 PM, Stephen Boesch <[hidden email]> wrote:
I have made no change to the build: this is a clean install from git sources.  So the comment about zeppelin to use 0.0.23 vs 0.0.16 .. the question is : why  is the build selecting that version. I have made no customizations. 

re:  "try again":  I have tried to build this a few times before venturing to contact the mailing list.

2015-10-13 2:31 GMT-07:00 Corneau Damien <[hidden email]>:

Zeppelin is supposed to use 0.0.23, but your logs are showing 0.0.16

On Oct 13, 2015 6:21 PM, "moon soo Lee" <[hidden email]> wrote:
I'm using os/x yosemite and maven 3.3.3, too and i have no problem building zeppelin-web module.

Here's related issue https://github.com/eirslett/frontend-maven-plugin/issues/179. The issue is resolved and Zeppelin uses 0.0.23 version which is version with the fix. 

Can someone also help to try build zeppelin-web module if you have os/x and maven 3.3.3?

Thanks,
moon

On Tue, Oct 13, 2015 at 10:57 AM Stephen Boesch <[hidden email]> wrote:
os/x yosemite  and maven 3.3.3

2015-10-13 1:06 GMT-07:00 moon soo Lee <[hidden email]>:
Could you share your OS and maven version?

Thanks,
moon

On Mon, Oct 12, 2015 at 4:39 PM Stephen Boesch <[hidden email]> wrote:
I have cloned from git and run:

   mvn clean package -DskipTests

The core and engine build but the web Application does not:


INFO] Reactor Summary:
[INFO]
[INFO] Zeppelin ........................................... SUCCESS [  1.274 s]
[INFO] Zeppelin: Zengine .................................. SUCCESS [  2.554 s]
[INFO] Zeppelin: Spark .................................... SUCCESS [  3.773 s]
[INFO] Zeppelin: Markdown interpreter ..................... SUCCESS [  0.128 s]
[INFO] Zeppelin: Shell interpreter ........................ SUCCESS [  0.097 s]
[INFO] Zeppelin: web Application .......................... FAILURE [  0.172 s]


[ERROR] Failed to execute goal com.github.eirslett:frontend-maven-plugin:0.0.16:install-node-and-npm (install node and npm) on project zeppelin-web: Execution install node and npm of goal com.github.eirslett:frontend-maven-plugin:0.0.16:install-node-and-npm failed: A required class was missing while executing com.github.eirslett:frontend-maven-plugin:0.0.16:install-node-and-npm: org/slf4j/helpers/MarkerIgnoringBase
[ERROR] -----------------------------------------------------
[ERROR] realm =    plugin>com.github.eirslett:frontend-maven-plugin:0.0.16
[ERROR] strategy = org.codehaus.plexus.classworlds.strategy.SelfFirstStrategy


So how to build this?